Is there a problem using Internet Explorer 11 for these applets that require the JRE? Just wondering if there is a good enough reason to drive yourself crazy and saddle your users with a vulnerable browser just for this one webapp.

The wiki How Tech Team also followed the article's instructions, and validated that they work. Keeping your Internet browser updated will allow you to take advantage of the newest browser features and also help protect your system from any recent security breaches. If you're more interested in anonymity, I recommend Firefox.

By default, your Internet browser will update automatically; however, you can also check for and install browser updates manually. You should do some research on the benefits of each browser to decide which one would be ideal for you.

Click (or double-click) your favourite portable Firefox shortcut and have fun!

Conclusion This method also allows you to change your portable Firefox to the language version of your choice or if you are feeling adventurous, to try the latest beta and alpha releases of Firefox without affecting your regular install of Firefox.

Have you been enjoying all the goodness of portable Firefox, but find updating it to the newest version a problem?

Now you can update your portable browser as easily as your regular install of Firefox.

I am very happy with firefox, but it keeps updating making it incompatible with my java based apps.

I can't update Firefox until they update the apps. So far I have modified all settings in firefox to not update. I have blocked just about everything in the firewall I can find that even remotely connects to mozilla.

Now you are are ready to install and have your portable Firefox updated to the newest version.